FIXED Tuesday 11th February 2020 02:20:56


Resolved - 11/02/2020 01:30:56 UTC


developers check failed (server time: 11/02/2020 01:20:56 UTC)

Get https://developers.grytics.com/: dial tcp 52.59.223.92:443: getsockopt: connection refused